Error from Google recaptcha admin page "site not verifying"

I setup Google recaptcha on all of my forms and it all seems to be working well except for an error message that appears that top of the screen when I go to Google’s recaptcha admin panel:

“We detected that your site is not verifying reCAPTCHA solutions. This is required for the proper use of reCAPTCHA on your site. Please see our developer site for more information.”

I’m no developer so clicking the link to the developer site doesn’t tell me much. Has anyone else run into this problem?

Here’s my read-only link: Webflow - Marketing Innovators

Thanks!
Jason

Hi Jason, did you get an answer on this issue? I am getting the same error and I have not been able to fix it.

thanks,

Same problem here. Any help would be great

Same here. Has anyone found a solution to this?

There is a page in the Webflow University that I recommend you review if you haven’t.
It should help you resolve your issue.

If you are still stuck, let us know.

Nothing on the webflow university help page answers this question. All of those steps can be done properly and you can still be receiving this message in the recaptcha console.

I fixed this issue.

Here’s what you can try:

  1. Open your site’s form settings: Design Responsive Websites - Webflow.

  1. Disable the spam filter in the “Spam filtering” section.
  2. Reactivate ReCAPTCHA, save changes, and make sure it’s added to all forms in the Designer.
  3. Publish the site and test the form.

Please ensure ReCAPTCHA is added to all forms if you have multiple.

Let us know how it goes. We’re here to help.

We’re experiencing this issue also and I’ve followed your recommended steps @adnanaheer (thank you). The message received in the google recaptcha console is:

“We detected that your site is not verifying reCAPTCHA solutions. This is required for the proper use of reCAPTCHA on your site”

Our form is using webflow native form but posting to salesforce.

If anyone knows a solution to this that would be greatly appreciated, as we’re getting a huge amount of spam bots hitting the form.

Thanks!