Can't get DNS to point to Webflow hosting correctly

Followed the instructions to connect custom domain. Both custom domain tabs say ‘connected’. Typing address in search bar redirects to and it doesn’t work.

Host is HostPapa and am using the DNS Zone Editor in cPanel to redirect. Have to type-in full domain for A record as cPanel doesn’t accept ‘@’ notation. Also have to use in CNAME record because again, cPanel doesn’t accept simply ‘www’.

What am I doing wrong?

In cPanel you should be able to add domainname.tld. as a reference to the @ or root. So, in your case it would be for the name with webflow IP and for the www subdomain it would be with a value of Notice the use of trailing periods in the name values.

Reach out to your hosting provider for assistance if needed.

Here’s current settings and results.

Screen Shot 2022-02-08 at 9.54.46 AM

Just queried Google DNS


Clear your DNS Cache on your local machine. Should resolve the issue.