Can not enable hover functions

Hello I´m new here and probably a silly question - I´m trying to build that nice tab-section shown in the Webflow site building tutorial with these hover effects. When I want to apply the effect to the active tab with a class (or any other element I tried) and go to the settings panel and activate hover in the “States” dropdown the Effects panel is greyed out with a message: “Transitions are disabled on hover/pressed/focus states. Instead add a transition on the default non-state class.” Perhaps someone can help - Thanks

Hello @Gerhard,

Could you share read-only link to your project (here is guidelines so we will check possible reasons of this issue.


Thank you Anna!


I’m a newbie too and it seemed odd at first to me as well, logic says that you add the transition while you’re in the “hover” mode, but this is not the case.

Add your required states whilst in “hover” mode, i.e. Colour, shadows etc. Go back to the “normal” state at the top of the settings panel, then go to the bottom of the settings panel again and add the transition from there, whilst the object is selected.

You should be able to hover your mouse over the object and see the transition in effect.

Hope that helps!

1 Like

Thank you Markos - so easy would not have found this out alone :wink:


Yes, @magicmark is absolutely correct. Only one thing I want to add, I would STRONGLY DO NOT RECOMMEND to use option “All” in the transitions, because it cause problems in the Safary browser. Instead, choose the option which is matching changes that you did for hover state. You can use as many options as you wish.


1 Like

Thanks al lot Anna, a grat help. Meanwhile I have another problem. The Navigator is a great help vor me. When I select ie a section there

and want to switch to the styles panel as usual I can´t make any adjustment because the app shows me only the class field and no further interactions not even to submit a class is possible. Tried to close everything log out, log in again nothing helped.

Thanks Gerhard

You can add changes (style) to element only if you will give it a class actually. Some elements can be styled in general (will be styled tag, it means all elements with particular tag in whole site): it is <body>, <a> (all links), <p>, <blockquote> etc. But most of the time it is better to give glasses for style elements.

Hope this screencast can be helpful:

Thank you so much for this "persona"l help. I understood the concept but going to the class field the cursor turns to a hand and nothing can be entered. I switched over to Safari from Chrome - everything worked fine until I reached the two sliders in the “Wohnen Section”. I got a message kind of “something went wrong with saving the site and should”. Since that moment the class field is again not accessible anymore

Well, I think we could report it like a bug.
If it is possible, make screenshot of this issue, please and create topic in the “Bug” category with all possible information.


Was not necessary, system runs smoothly again.

Great app - much fun.

THX again and all the best to you!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.