Streaming live at 10am (PST)

Button hover out of sync

i’m having some very weird behavior with my button and hover state. i made a separate project to show what is going on.

if you look at the padding-top in the default state it is 12px.

i changed padding-top to 32px for hover which displayed properly in the interface when i first added it. however you will see that the hover state is now displaying 12px on the interface but is actually 32 px (which you can see when you hover over the button as well as in the exported code below).

some kind of way the properties are out of sync.

also it looks like in the exported code the properties are being rewritten for the hover state even when changes are not made. i would assume only the button properties that were changed for the hover state (i.e this case padding-top) would be written to the button:hover property.

Here is my site Read-Only:

Same thing is happening here… the padding is correct but does not update on the dashboard view.


Same here, and it’s driving me up the wall :expressionless:


@cyberdave any thoughts on this? seems like i am not the only one with this issue. the issue still persists this morning.

1 Like

Same thing here :grimacing: It’s happening to all of my projects.

I’m trying not to panic! haha

Not sure if I’m experiencing the exact problem but button selectors are acting strange. Can’t set hover styles on buttons. Hopefully there will be a fix soon :slight_smile:

1 Like

Yay!! I think it’s fixed.

​Thanks for reporting this issue. A fix was deployed for an issue where the style panel was not updating correctly when changing rules in the linked rule dropdown.

​I tested on one of my projects and it seems working correctly now.

​Please let us know if any further issues.


Thanks David! Everything appears to be fixed now. :tada: :tada: :tada:

I did notice one lingering issue that I’ll share in case others find the same thing: Any element whose hover state was edited while the bug was live saved the wrong settings. It’s an easy fix though. Just option-click to remove all of the unwanted styles and redo your hover effects. I only changed one element, so it wasn’t hard for me to fix.

Thanks again for the quick fix! Really appreciate it.

1 Like

same. it appears to be fixed for me as well. also had to fix anything that was added while the bug was live.

Hi Guys,
I’m new to the forum and relatively new to Webflow. Just trying to do an online portfolio :slight_smile: I still have problems with the hover function. I created two new buttons and added “hover” from the states drop down but for some reason the “fill” option is not visible.

The button looks like I want it so far but I would like to add a green hover background colour (green of the current border) and make the font white on the hover. Whenever I deselect the button the “hover” disappears from the selector menu as well…

How can I do this? Am I blind? :slight_smile:
Thanks in advance,

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.