Bluehost Free SSL fail

Hello. I have had my site exported to and hosted by Bluehost for a couple of years. It has been brought to my attention that Google requires SSL security as of July 2018. I worked with Bluehost’s tech support to try and get their free SSL to work, but they got stuck after helping me turn it on and set up a redirect to https://www.vanetc.com. (If I type: vanetc.com into my Chrome browser, I get Chrome’s little i for insecure site next to my URL. If I type https://www.vanetc.com into my Chrome browser, I get a “Secure” label. Bluehost said I had “Mixed directives” and they don’t have an affiliation with Webflo, so they couldn’t help me with my Webflo code. Here is my read-only link:

https://preview.webflow.com/preview/fixed-dvedesign-net?preview=62b46cbcf22eb8b75afb1b3db4ef0819

If any of you could explain what “Mixed directives” are and point out how I can un-mix them so that my site shows up as secure, I would be most appreciative!! I notice that my site shows up as secure in Safari, though it shows up as https://vanetc.com (sans the www). Firefox behaves just as Chrome does.

Thanks in advance!
Dean

Do you have access to the .htaccess file in your root directory?
(can be found in “public_html”)

If YES, add these lines to the top:

RewriteEngine On 
RewriteCond %{SERVER_PORT} 80 
RewriteCond %{HTTP_HOST} ^vanetc\.com$|^www\.vanetc\.com$
RewriteRule ^(.*)$ https://www.vanetc.com/$1 [R,L]

I have access to the directory, but DO NOT see .htaccess

create a new file called “.htaccess” including the period in the beginning, add lines above, place in public_html folder

Thanks so much for your help Sam_G, but I can’t seem to find or generate an .htaccess file. When I search for it within the Public_html folder, I get (attachment 1) when I choose one to double click, it reopens the Public_html window with the same content rather than an editable file (attachment 2). If I try to add a new file and name it .htaccess, Chrome tells me I can’t because it already exists. The multiple .htaccess files in attachment 1 may be from when I tried adding new ones through Safari which did not provide an explanation like Chrome did. (“Already exists” error) Any suggestions?Attachment%201Attachment%202

Oh… also, if I try to add the .htaccess after the Public_html/ in the upper left search input, this is what i get: (Attachment 3)