Animation Loop Not Looping - Even With Option Checked

Hi there! First time poster, and I apologize in advance because I realize this has been addressed before, but I still can’t seem to get an animation to loop despite the “loop” option being checked. It’s a logo animation I imported from after effects via a json file on the top left of the page in the navbar.

Initially, the animation was having “blinking” issues when I set it to loop in the basic lottie animation settings. I’d then read about a remedy for that where I needed to set it to play 99% of the animation via an interaction. So after trying to add an interaction via the “when page starts loading”, I did my best to configure the animation, but it simply stops even with the loop box checked.

It’s about a 5 second loop. I’ll admit, I don’t fully understand the settings I’m looking at (i.e. the easing I just have set to linear and “4.99”). I also tried adding an animation to loop when the page finishes loading, but I must be doing something wrong.

[Here]( is my site Read-Only

I’d love it if someone could take a look! I feel like I’m just overlooking something small.

Thank you!

I deleted this and then it was looping, I guess you didn’t need any interaction set up to loop this.
Screenshot 2020-05-21 at 15.30.41

1 Like

Thank you for taking a look!

Deleting the interaction does help it loop, but then I have a random issue of having the animation “blink” everytime it restarts :frowning:

haha I guess I’m just trying to have it repeat constantly, and not blink at all. Any ideas?

Hello :slight_smile:

I had a look and fiddled around a little and may have solved your problem. See screenshot for how to set up the interaction. You just need to add another Lottie action before the one you have with the timeframe at 11%. Seems to work for me. Let me know if you don’t come right :slight_smile:


OMG THANK YOU. I have no idea how that works or why, but YOU ARE AMAZING THANK YOU FOR HELPING!!

Solution worked perfectly. Can I ask how you decided on 11%? :slight_smile:

Also, easing is set to 0?


No problem :slightly_smiling_face: I just fiddled around with values until it didn’t jump - no real solution there. And set the easing to 0 to test and it worked. I wish I had a real answer for you. Sometimes I just trial and error until something works :slightly_smiling_face:


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.