Streaming live at 10am (PST)

Anchor links failing upon publish- work fine in preview and live until today

HI Webflow team and others,

Yesterday, my buttons with in-page anchor links worked fine. now they don’t. I can manually type in an anchor ID and that works, but all the anchor link IDs have been stripped from my 11 buttons mid-page. Anyone else having this issue as of late? is the site. the section about “How we differentiate” that has numerous buttons in it is where the issue lies. Again, works fine in preview, but when viewing “published” test page, the anchor links are there, but missing the IDs to send someone to the correct place.

Very urgent project - please help!?

Kind thanks~

Here is my site Read-Only: LINK
(how to share your site Read-Only link)


I just found the same issue, and likewise, the url of every link is set to ‘#’ on publish and is missing each anchor name. There is a problem in the publishing code.

Can you change the problem type from “layout” to “bug” for this report?

yes! Will do immediately!

Thanks for confirming I’m not crazy!

1 Like

I’m seeing this as well. Anchor links are getting wiped out on publish. Code on live site confirms.

Hello everybody. same problem. links only have # in custom code all the time

Same problem. Please let me know when fixed / how to fix. Thanks

I’m having the same issue! None of my subnavigation bars are working site-wide. I just signed in and confirmed on multiple pages that the links were still there and matched the page sections - they work when I click “Toggle Preview” in the designer but not when they are published.

Hope this helps! Let me know if something is unclear!

Quick fix for you guys while webflow hasn’t pushed the fix yet:


The in-page linking does not seem to work in the published version of my website. It works fine in preview mode.

The PAGE is FAQ, and the link is the Featured Question Link.

Here’s my preview link below.

Any help is much appreciated!

Here is my site Read-Only: LINK
(how to share your site Read-Only link)


I’m having exactly the same problem, Nav Bar Page section links, working this morning, now nonfunctional.

Again, work fine in Preview mode, not when published.

Is this a wider Webflow problem or something I’ve done?

Interestingly when hovering over link, the website address comes up as “https://…” - i’m sure previously it came up with #something, but not 100%

I’ve been through many forum posts, tried a few things, but no bueno. :hot_face:

Only edit I’ve done today is add in a roll-over image change?


It looks like a Webflow issue, because I’m having the same problem with the published link, but I have a local copy of the site and it used to work as of yesterday.

It’s removing the actual anchor from the link when publishing.


Yes, I see the hash sign inside the anchor of my published version. Hopefully Webflow can address this soon. Thanks for looking at this!


Same problem here, so is this a confirmed Webflow issue then?! How many sites is this affecting?!!!


Same problem for me. Anchor link IDs getting deleted on publish.


Quick fix for you guys while webflow hasn’t pushed the fix yet.

Let me know if something is unclear


Hello everyone!
The Webflow team is already issuing a fix for this bug. Will update ASAP!

1 Like

Great news! Is this a fix that will update automatically when Webflow pushes the change or should I stay in the office so I fix it when it is ready?

Probably automatic, but @rileyrichter is a better authority to answer that :wink:

1 Like

Hi, everyone! Thanks so much for reporting this. The team has put together a fix and it’s in the process of being rolled out now. When it’s live, I’ll post here to let you know. You will need to republish your site to get those ID links working as expected again. :webflow_heart:

I’ll post here again as soon as the fix is live!

1 Like