Streaming live at 10am (PST)

Adding New Video links Crashes Designer (Showing Grey Screen)

Hey! I’m having issues adding new Matterport 3D videos in Webflow. I am not sure what is causing it now, as I don’t have any issues with the first 6 Matterport videos I added a couple months ago.

I have tried deleting and creating a new Video element, looking for alternate video links, trying the older Matterport 3D tour videos that I added in the past (they won’t work on the new pages either), and I tried using Youtube links just to see if they will work and they do.

Here’s a screenshot of the screen I am getting after trying to add the new Matterport video (or trying an old one that worked but on a new page).

I am trying to add this link ( to the page at

Any help as to why this is happening now would be appreciated!


Here is my site Read-Only: LINK

Hi @ZachSean

Thanks for posting and for letting us know about this odd issue!

Our team is working hard to get this resolved asap, but I don’t have a solid time frame for when we’ll have a fix for this.

For a workaround, you can use an <iframe> inside of an embed. I’m happy to provide more information on how to implement this if you’d like.

This workaround should help unblock you until the team has a fix in place for this.


Thanks, Brando! The workaround will work for now. Definitely let me know if/when you guys get this fixed :slightly_smiling_face:

This is happening on any video type, not just the one mentioned by the OP. I’m seeing it with vimeo links. Will use an embed for now, thanks!

Hey Brando, I’d love more info on using an iFrame? When I try to use Vimeo’s embed code it doesn’t fill the entire parent column width like it does when I use the Webflow video element. Any advice?

Here’s my share link:

It’s on the “Tripwire - Learn Module” page.


Hi @Chris_Scott

This is happening on any video type

Yes the issue appears to be affecting videos from multiple sources including Vimeo. Hoping to have a fix soon!

As for the embed, I think you’ll need to set a defined height. Try using this:

<iframe src="" width="100%" height="360" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>

Initially, I was able to add video components and add a youtube URL into each. Once I got to my third video component, it crashed. And it keeps crashing, every single time I try to add a youtube URL.

Vimeo seems to work fine however.

Here is my site Read-Only:

Try chrome incognito. Your read-only link is broken-link

oops try this:

It works perfectly for me!

Can you try to clear your cache?

Hi @Bboyneko, could you also help to share the youtube link you are trying to add? There have been a few reports of Vimeo video links not working for some links and our team is working to push out a fix for Vimeo links not working.

An alternative method is to use our embed widget and add the YouTube video as an embed.

I tried clearing cache, rebooting, I still have designer crash on me.

The only thing that worked was incognito mode. Does anyone know why that would be?

Hi @Bboyneko @Chris_Scott @ZachSean

Thank you again for posting about this and for your patience.

I wanted to let you know our team was able to push a fix for this — adding a video url to the video element shouldn’t crash the Designer anymore.

Please let me know if this solves the problem on your end :bowing_man:

1 Like

This fixed it for me! Thanks for rolling that out, guys. Appreciate the help!

1 Like

Happy to help @ZachSean — thanks for your patience while we worked on a fix :bowing_man:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.