White Label agency branding logo not updating

I updated to Agency plan, created both an SVG and png of a 300x80 logo. In my project settings under members I click and replace the Webflow logo. A pop up appears that the editor branding is been updated and instantly the logo reverts to the Webflow logo.
I thought it was a cache issue and tried an incognito window, I tried different browsers, I tried a jpeg even… It does not work.

Kind regards

Here is my site Read-Only: [LINK][1]
([how to share your site Read-Only link][2])
[1]: http://
[2]: Share a read-only link | Webflow University

Hi does anyone know of a solution? it doesn’t work and I upgraded specifically for updating the logo.
It looks like is being uploaded, flashes for a brief second and than the webflow logo returns in place.
Many thanks

No answer from support and is a bug. It works on a starter site but not on any of the hosting plans. I m on business and updating the logo does not work. It is rather strange that support just ignores all emails about a bug for days.