Urgent - unable to publish - please help!

I’m getting the response “Variant ‘Fair Paraguay Rum XO’ must reference a valid product” when I try to publish.

‘Fair Paraguay Rum XO’ is a product I tried to add as a product to the e-commerce CMS, but it kept giving me ‘unable to validate’ errors, or something to that effect an I couldn’t figure out why. I eventually deleted it and then tried to publish the other changes I had made to receive the error above.

I REALLY nee to be able to publish my changes and I’d also very much like to list this product.

Please, please help!


Sam, we in the community can’t resolve this one for you. Open a ticket with Webflow support.

I would say restore from a backup but that can nuke all the item ID’s and inventory.

Hey Jeff, thanks for the reply. I did that a few days ago. Hopefully they will respond soon.

Do you mean that if I restore from backup it might nuke ALL the items or just the items that i added after the instance that I’m restoring?

Each item has a unique ID which is used via the API and integrations. A restore replaces this ID which can create problems for anything that relies on it. As for the inventory count, as I understand it, that can be lost as well. Not idea for sure. You should be careful and fully research the impact of doing a restore with Webflow before committing a change.