Trouble Changing Slug for Specific Page(s)

Hello,

I’m trying to change the slug name on a few of my webpages but am having difficulty. I got the alert as shown in the attached screenshot and updated through the Hosting, per the instructions. However, once I published the site, the slug is still “firststop-copy” when I want it to say “firststop.”

Any help would be greatly appreciated.


Here is my public share link:

https://preview.webflow.com/preview/josh-parlettes-fabulous-project?preview=75becffd726efc200f5ea7a6324c2777

I forgot to attach the screenshot. Here it is.

It looks like you haven’t changed the slug on that page yet.
You need to change the slug field shown in the screen shot.

When I changed the text from “firststop-copy” to “firststop” an alert generated stating that “the slug will break external links to the page.”

What does this mean?

It means that if anyone tries to go to the old URL they will be sent to a 404 page. OR if you have typed that url in anywhere the link will go to a 404 page.

So once you have changed the slug in that field you can set up a 301 redirect in the project settings. This will push users to the new url rather then sending them to a 404 page.

If you haven’t published the site live and haven’t hard coded that URL in anywhere then it might not be necessary to setup a 301 redirect.

Hope that helps.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.