Streaming live at 10am (PST)

Struggling with a simple iframe

I read ALL iframe-related topics but I’m still in the dark …
I try to embed a simple iframe. I took ready-to-embed link provided by the website itself from here: Cybersecurity Career Pathway
I need to embed it on my client’s website, so I can’t share the actual link, but I also tried it on my personal portfolio website just for testing proposes. It does not work :sob:
I tried other links to different websites. Some of them work, some of them don’t… I don’t get the pattern. Can anybody explain to me why the magic happens only in 1 case out of 5?
PS. I enabled scripts in Chrome.

This is my read-only-link Webflow - Web Designer Karina Demirkilic
The iframe is at the very end, after the contact form. No hard feelings I will delete it in a day or two, I can’t have this huge white space on my portfolio forever :crazy_face:

@Bonakaren Looking at the error on Chrome console. It was because you’re loading the Iframe on HTTP (Cybersecurity Career Pathway) instead of HTTPS (Cybersecurity Career Pathway). Changing to this link should solve the issue.

Okay @dennyhartanto , I added ‘s’ to the source link and I have some progress. Now it looks like:

Still not want I try to get :sweat:

The source may have set ‘X-Frame-Options’ to ‘SAMEORIGIN’ which means the content can only be loaded on the same domain.