Spline embed not showing correctly

I’m attempting to embed spline elements into my header. I’ve tried using several different spline project URLs and they all appear as the same spline project ( a 3 card stack) that is not my project. I’ve dumped my cache, tried multiple spline project URLs, and tried a separate browser.

This is the reason I signed up for Webflow, so I’m really frustrated. I’ve seen other users report that Webflow won’t reflect new changes to their Spline projects, but my projects won’t even show up at all. Suggestions? TYIA!

Webflow site: Webflow - Dunaway Smith2
Spline project: dunawaysmith

When looking at the embed code, it’s clear that Webflow is actually using a placeholder URL for the Spline project, rather than my project file.

I discovered the issue and wanted to report it here, in case anyone else runs into this.

There are multiple URLs that are generated in the export window of Spline. In Webflow, you have to use the one titled “Code Export” rather than the “Public URL” one.

2 Likes

Thank you! this was driving me nuts! You’d think someone from webflow would explain that somewhere lol

THANK YOU SO MUCH! I spent HOURS trying to figure out why I couldn’t get it to work until I stumbled into your comment which made it work for me!