Small twitter summary card image is never displayed when sharing links

I’ve been having very perplexing issues with twitter card images in all the sites I build in Webflow, despite always using the recommended open graph/seo settings.

When sharing a url in twitter, it will sometimes choose to display a small summary card and sometimes a big one. The problem is that when it displays a small card, it NEVER displays an image (not even a cropped version of the large image) and I can’t for the life of me figure out why. I have scoured the webflow forum and twitter’s docs and cards-specific forum and can’t find the answer.

Below are some screenshots to help show the issue:

In this example you can see the Twitter card validator shows that the large summary image will be shown and everything looks ok (no errors in the log). However when pasting the site’s url into a tweet it displays the small summary card but NEVER with the image.

Here is another example from my folio site where in the validator log it says it has found the OG image I uploaded, however it still will never show this image when in the small card format as you can see in the validator.

Whether twitter displays the pasted url to share as a small card or large one seems completely random. For sites that show the large card when sharing the image works fine.

Can anyone help explain why this is happening and what I can do to ensure an image will always be displayed no matter whether twitter generates a large or small summary card?

They’re showing for me. Is it possible it just hasn’t crawled fully?

hey @joejola , thanks for the response; I don’t think so as my site has been live for years and I still get the issue. I wonder if it might be a weird cache issue as after hearing that it worked for you I tried hard refreshing twitter again and it swapped to the large image format - still no image at the small size but weirdly now Twitter chose to display the large format on that occasion. It’s very confusing. I dod see some people having an issue when they try and share a link for the first time but this kept happening for me after multiple attempts and multiple refreshes. Anyway, thanks again!