Simple fixed / no scroll page

Hi community,
I want to make a very simple homepage that doesn’t scroll : the body section should fill the whole screen : no scrolling at all.
I tried to set the body height to 100 vh… but it doesn’t bring my the whole body page on the designer. Could you help me out ? Thanks a lot, I have tried to find the solution in the whole forum without finding. Best regards !


Here is my site Read-Only: Webflow - Maison Amara

1 Like

Hey, As a starting point you can set max-width to 100vh and also set body’s overflow to hidden.

1 Like

Hey Nkatla,
I am a newbie in Webflow… when setting max width to 100vh and body overflow to hidden, then on screens sizes where my main background picture is smaller in pixel than the screen width, the whole page takes like 2/3 of width and height rather than the whole screen ; while picture width is set to 100% so I don’t get it. Do you see why ? Webflow - Maison Amara
Thanks

Sorry my bad, looks like my head was somewhere else while I was writing my previous comment lol, So let me correct my answer to thisL: you can simply set height to 100vh and keep overflow hidden.

Thank you, now I must fix the appropriate screen behavior on each view point. Thanks again and have a nice day.