Preloader Animation Once

I am trying to make the preloader only happen once, not everytime you return to home page. I tried copying the home page just redirect the back buttons but that messed with the read mode button so that didn’t work either. And I watched this https://youtu.be/mFbk1O_8Nio but he did not explain how to even get to where you change the code on your Webflow site…
I got the preloader from Webflow - Damon's Supercool Project
develped by SketchzLab


Here is my public share link: Webflow - Damon's Portfolio
(how to access public share link)

Hey @djgoss !

You can find the custom code used to manage the cookies in the page settings (Page 10) of his site at the bottom in “Inside /head tag” like he shows in the video.

Thanks @DasSean, I copy and pasted in that same spot on my Home page but it still didn’t work, any clues?

You are welcome!

Yeah so basically in the code it needs to reference YOUR wrappers.

  • Page Wrapper (Which you don’t have right now (you can wrap your whole website except the loading screen in “page wrapper”) and you don’t have to change the code for this if you name it “page wrapper”)
  • Loading Wrapper (c-preloader) = (hack10-loading-wrapper) so change that reference (it is highlighted in the photo below :slight_smile:

I hope this you get moving in the right direction. The code references direct divs so you need to change them to fit to your website.

Always,

Sean

Ill try it, thanks so much @DasSean

1 Like