Navbar Being Pushed Down After Trying to add FB Pixel

Hey friends,
I was trying to add a facebook pixel to my header code (first via Google Tags Manager, then manually installing), and somehow the following code became visible and pushed down my navbar:

var _learnq = _learnq || []; _learnq.push(['account', 'z8bQPj']); _learnq.push(['identify', { // Change the line below to dynamically print the user's email. '$email' : '{{ email }}' }]); (function () { var b = document.createElement('script'); b.type = 'text/javascript'; b.async = true; b.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + ''; var a = document.getElementsByTagName('script')[0]; a.parentNode.insertBefore(b, a); })();

It was clearly something I’d added when I was fooling around with Klaviyo ages ago, but I have no clue where I added it. I deleted all the code I’d addedin the site-wide custom code section. Then saved, and published… however it’s still the same. Can anyone lend a hand?

Thanks so much!

FYI: You are missing an opening script tag on that code block. Scripts need to be wrapped in <script> </script> opening and closing script blocks. Refer to ->

Oh ok @webdev . I honestly haven’t any clue where that code is located so I can do away with it (as I don’t need it). It’s not in my project settings’ custom code or my home page’s code under it’s settings. But it does show globally, so I’m confused. Any ideas?

Can you share your read-only link please?

Sure thing @webdev thank you!

Take a look at your project settings > custom code > before body (head) . It is in with your memberstack code. I can’t view project settings, but that is where it is in your source code.

Oh my. I feel like an idiot. It’s all greek to me! Thank you so much Jeff!

As I tell my martial arts students, “When you have walked a thousand miles in the studio while practicing everything shown, you will understand the basics.” There is a lot to learn. Each failure is a lesson.

1 Like

@webdev are you able to help me with one other thing? I’m trying to figure out why my cookie consent banner is appearing on each page after consenting. I followed this guide step by step (or so I thought) and I can’t figure out what I’ve done wrong?

Not tonight. I worked through the holiday last week. I am off to have fun. Post it as a new topic to get some visibility.