Streaming live at 10am (PST)

Mobile menu not closing on external/internal link

Hi All,

I’m fairly new to WF and really impressed with it so far (I used to handcode all my sites, but WF is saving me lots and lots of hours messing around with breakpoint and the likes). So it may be me misunderstanding, but I have a problem with linking to section anchors from navlinks. I “fixed” it, but ran into a new problem, stated in the subject line.

So, I have:

  • 2 pages, home and privacy
  • 1 navbar, with some links to section anchors on home-page

This doesn’t work from privacy-page obviously, so I adjusted:

  • 1 navbar, with external links to /#<anchor>

Although this seems a bit weird (external link to internal page), alas this works from both pages.
But… with the external link navitems, the mobile menu doesn’t close :frowning:

Since I have only 2 pages, I tried to duplicate the navbar symbol, but this is no option: when it’s already a symbol you can’t make a new one out of it and there’s no duplicate action (at least I didn’t find it). The reason for duplicating was my attempt to make a ‘home page navbar’ with rel.links to the page, and a ‘privacy page navbar’ with “external/internal” links to /#.

So, now I’m stuck. I read in another post, there was a small piece of custom code needed to make this work. And although the code itself is no issue, I think it’s odd to have to resort to this for something pretty simple.

My question is: how to make navlinks work with section references across different pages?

I can think of multiple (easy, from a users point of view) ways of doing this:

  1. allow to enter a text when specifying a Page navlink, which will be appended to the URI
  2. allow to select a section after choosing a Page navlink
  3. allow to select a Page/Section on the Section dropdown

I assume there’s one of these or alike on some future storyboard and I’m not sure any of these will solve my ‘mobile menu not closing’ issue, but since it worked with just internal section links, I hope it will.

Any help in making this work (preferably w/o custom code, just because one shouldn’t need that for such a simple use case) is greatly appreciated. Or just some insight ‘why this doesn’t work’ would be helpful too. Thanks.

https://preview.webflow.com/preview/funle21?utm_medium=preview_link&utm_source=dashboard&utm_content=funle21&preview=e6e370323ac3eaaa87f57efc84ebdbde&workflow=preview