Streaming live at 10am (PST)

Issue with actions on forms

Hi, I have been using Action on forms for some time very successfully to send form data to an external API using a form to JSON transcriber.

Today for the first time I am having problems. The Action box in Forms seems to hate https: and is prefixing all my “actions” with http?

Webflow Bug

I have tried it on a clean test site and it still tries to prefix http to all my actions.

If I put the URL after the http:// that webflow seems to be adding it does work but I get a warning about it being unsafe.

Chris


Here is my public share link: LINK
(how to access public share link)

1 Like

I’m also having the same problem. Just touching one of my working forms applied this prefix and broke it. :neutral_face:.

I’ve even tried to add it as a custom attribute below and it’s saying that action is reserved.

Please fix this or provide a workaround as all of my sites are going to break whenever I need to update a form.

Webflow fixed this within 6 hours of it being reported. Well done Webflow.

Hey Chris.

I’m still getting this problem on my end (prefix http:// is being forced). Did this go away for you?

Thanks,

Andy.

Yes it did, I raised a ticket and they fixed it.

I hope it hasn’t returned!

I think it’s still a problem (maybe they fixed a specific project for you?). I just created a fresh project and the http:// is still being forced.

Form Action Test

Just now

Maybe my requirements are different. But I need to be able to enter “/thanks” without HTTP or HTTPS. This problem will break all my form integrations with netlify forms.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.