Streaming live at 10am (PST)

Image paths for Webflow CDN hosted images vs exported site images


when I export my projects and publish them on my own webserver - the images are perfectly placed into a /image/ directory and the original file names are used.

But, when I use a custom domain and leave the images on the webflow server, the images are not available in an /image/ folder. The img URL looks like:


Is there no option to use the custom domain instead of


1 Like

Hello , @michael!

There is the difference between custom domain and exporting site to another server.

Your domain name is the name of your site or your url and can be purchased by going to a domain name registrar.

For make your website to appear on the Internet, the files need to be uploaded to a server. These can be “hosted” at a hosting.

When you are exporting site, next step is uploading it to the server (hosting).
When you just using custom domain and leave site on the Webflow - it means that all files is still on the webflow server (hosting).

Hope I was able to explain correct.


Hi @sabanna,

to clarify my question:

When I upload the image “picture.jpg” into a webflow project and export the whole project in order to host it on my own server, webflow creates an image folder and the image is availabe using the following url:

That’s exactly what I want the URL to look like.

But, when I use as a custom domain and webflow as “hosting” service. The image is not available via the custom domain, but only via a webflow subdomain:


What I would prefer is that my pictures are reachable via my custom domain when using the webflow “hosting” and not via a webflow subdomain.



Hi @michael, at the moment, when a site is hosted in webflow, we serve the images using a CDN (to make it faster and more reliable worldwide. At the moment, custom domain paths are not supported for sites hosted in Webflow for those CDN hosted image assets.

This is a good idea though to make this a feature option, I have converted this to a Wishlist

​I hope this helps :slight_smile: Dave


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.