How to remove constant footer in mobile view

Hi.
So, the desktop versions appear fine, however, when it comes to mobile view the footer is fixed and can always be seen. How do I remove this? I tried to make it inline for mobile but still didn’t change. Also, there seems to be space above the header - dark grey above black border which you can see in pics I will attach. Also, why does the box have rounded corners for adding email? And is there any way to remove all the style manager words that aren’t being used? It just looks messy.
If someone has any answers that would be great.

Thank you.!

https://preview.webflow.com/preview/the-hotel-curator-launch-page?utm_medium=preview_link&utm_source=designer&utm_content=the-hotel-curator-launch-page&preview=2562f833a2637534bbf4755d7c6f6858&mode=preview---------

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

@chicane could you share your read-only link? Here’s how https://university.webflow.com/article/sharing-your-sites-read-only-link. That way we’ll be able to take a look at what’s going on :slight_smile:

1 Like

Wow, lots of questions haha. Let’s go:

  1. Just go down and set the footer position:staticor position:relative. That problem doesn’t have anything to do with display settings that you were messing with
  2. Check all the margins settings for the elements surrounding that area, or if there is any kind of element that is with 0% opacity over there.
  3. Just click on that element, and set it’s border-radius: 0pxand then you’ll get rid of the rounded corners.
  4. While in the designer, press G and click on “clean up” on the top-right side of the screen.

@chicane thanks for adding your read-only link.
Seems like @Jeandcc stepped in to help you out between me asking for the link and coming back online again :slight_smile:

I just guessed things. I’m not really sure if it fixed her problems or not hehe. Feel free to stay here Sarah

@Jeandcc no worries, your suggestions were good.

1 Like

@chicane Other than what Jean already suggested, I’d also clean up your structure. You’ve got quite a few wrappers that aren’t needed. It’s not a super bad thing but they don’t serve a purpose so they just add weight, clutter and it makes it harder to see what’s going wrong. Here’s the structure I suggest.


I removed the ‘page wrapper’‘page content’ and ‘div block 3’ since they didn’t serve a purpose. They wrapped a wrapper, it’s kinda like putting a smaller box inside a bigger box.

[quote=“Jeandcc, post:3, topic:88582, full:true”]
Wow, lots of questions haha. Let’s go:

  1. Just go down and set the footer position:staticor position:relative. That problem doesn’t have anything to do with display settings that you were messing with

So all are relative. Is this correct? It seems to be working!

  1. Check all the margins settings for the elements surrounding that area, or if there is any kind of element that is with 0% opacity over there.

I think it may just default to have space above and below or am I wrong?

  1. Just click on that element, and set it’s border-radius: 0pxand then you’ll get rid of the rounded corners.

There is no border set at all. It just creates it automatically on mobile. Not sure if there is code to remove this. Worked out this did require code and now fixed!!!

  1. While in the designer, press G and click on “clean up” on the top-right side of the screen.

I worked out I have info on 404 error page - that’s what I was trying to remove.

Thank you! I think I have worked it out and deleted those extra boxes.

1 Like