Streaming live at 10am (PST)

How to disable smooth scrolling?

Hi.

Is it possible to disable smooth scrolling within a webflow project, or even at account level? We have issues when converting our webflow builds into woocommerce sites as the smooth scroll kicks in when clicking product info tabs on a single product page.

We’ve resorted to removing part of the webflow.js code that is exported but this is not ideal as the section of code also has the webflow tab code too. We’ve trawled the forums but the only request similar was here, How do you disable smooth scroll on same page section navigation, but that has received no responses.

Thanks in advance.

H @Mark_Urbansoul - Webflow does not provide an option to disable it, browsers can override it, but the only way currently to remove it is to modify the code in the core JS. Would be nice if Webflow used modules.

Hi @webdev

Thanks for getting back so quick. Yes, I absolutely hoped that modules would be packaged depending on feature usage with a project. Would have been great and a much leaner codebase when dealing with exported sites. Or even the option to select which modules you’d like within a project, much like the way modernizr allow you to select detects.

I guess I’ll carry on editing the core js file. Thanks again Jeff.

Mark

Have you tried adding a custom attribute to the body of the page :
data-scroll-time of 0 ?
I think this still works

Thanks for replying Dorian , but I needed to disable the scroll interference completely. I’ve removed it from the core, as per Jeff’s reply, and it works perfectly.

Thanks again.
Mark