Home button is always set to current - even when not on home

Hi, I have this strange problem in my nav menu. When I link the home button to the home page, it always ends up in “current” state, even when I’m not on the home page.

In the screenshot below, I am on the “offerings” page, but because home is also showing as current, the colored highlighting of the text is incorrect (dark blue instead of black). Does anyone know how to fix this?


Here is my site read only link: Webflow - Trulitica

3 Likes

Strangely, my read-only link doesn’t reproduce this problem. Wonder if it’s a bug of some sort in my UI.

1 Like

A few people reporting similar issues lately but I don’t see it anywhere live.
Try publishing your site and see if it happens there.

1 Like

Looks like the issue isn’t happening on published live site either. I think I’ll consider this resolved for now. Thanks

1 Like

also experiencing this issue. Doesnt appear on published site, but in editor Home link has current tag on other pages

1 Like

All of this may be an artefact of localization. Check to see if you have a default locale set under your designer site settings ( bottom left gear wheel ).

I answered a post this morning relating to path truncation which I think is also a glitch relating to localization’s new path-formation mechanics.

1 Like

Was having a similar experience to @Tristan1

Issue wasn’t taking place in the live publish version:

However, in preview mode, the home button refused to shake the current state. Quite annoying:

Followed what @memetican said above and configured a localisation:

It solved the problem in the desktop preview mode:

However, issue is still persisting in the mobile hidden menu preview mode :frowning:
image

same issue. bug in the designer, but does not occur on live site.

I really, really wish Webflow would let us select “current” as a state, just like we can with hover, etc. It’s too much of a pain to get “current” to work easily in many scenarios.

Happening to my client as well. It’s a bug and it keeps us from adding “Home” tab to our navbar.