Streaming live at 10am (PST)

Hide simple fade-in interaction on mobile breakpoints, how?

Hi,

i just found out (after setting up all my interactions) that even tho you can deactivate them for specific breakpoints now, they keep their “initial state actions”.

initial_state_settings

How do you manage to build a simple fade-in when scroll into view that’s disabled on mobile?

my normal workflow:

1. set object to 100% opacity in viewport/designer (let’s say that’s the final state)
2. use initial state in interactions and set it to 0% opacity.
3. when scrolled into viewport -> fade-in over 500ms to 100% opacity

When I now disable this really basic interaction on mobile, it still keeps the initial state of 0% opacity which makes every object invisible on mobile and therefore the whole interaction useless, huh (?)

Am I doing it wrong? That’s exactly how I’m setting up interactions for years now. Why do you apply the initial state from the disabled interaction? :disappointed_relieved:

Thank you guys :slight_smile:

1 Like

Hey how do you disable interactions on certain breakpoints? Thanks

Hi, within your Interaction (where you choose the desired actions) scroll all the way down and you’ll see the same little breakpoint triggers you see in my first post :slight_smile:

1 Like

Hello, I’m having the exact same issue. The initial states of the interactions are kept even if the interactions are disabled on that specific breakpoint.

I have these image labels that appear on hover, but they’re not visible at all on mobile when I deactivate the interaction because it’s initial state is opacity 0%.

Are there any ways to fix this issue?

1 Like