Google MyMaps Embed acts up on mobile

Here is a video that shows the problem:

Basically in the Google MyMaps embed window, when you open a location and then tap the back button in the top-left corner it shoves you to the bottom of the page for some reason.

The strange jump happens on mobile (iOS iPhone Safari), tablet (iOS iPad Safari) but not on desktop.

Could it be my way of embedding it that’s wrong?

Live site:

Here is my site Read-Only:

Has anyone got any ideas? Or know somewhere (like a google expert forum) that I can ask?

Try adding this code to the page or site

    html, body {
        height: 100%;
        overflow: auto;
        -webkit-overflow-scrolling: touch;

It worked on my testsite for this issue.

Found this question over at product forums!topic/maps/TLjqDaqX73M

And he linked to a question at Stackoverflow

Hope it helps John :grinning:

When I visit Japan you owe me a sake :smile:

1 Like

It works just fine for me, thank you so much for the solution Jorn :slight_smile:

Vikas Kundu

1 Like

Thank you so much for researching this for me, Jörn. However it didn’t work on my site :confused:

I pasted the code in the head of my site, but for some reason it kills all my embed code and interactions on mobile… (not on desktop though)

Check here:

EDIT: Super frustrating since it does indeed seem to solve the problem on your test page, @jorn

No problem John. Your site works for me on iPad now. But the map doesn’t load on my phone.

Thanks again :slight_smile:

I don’t have any iPad to test with, but interesting to hear that it works there…

@Brando do you have any idea why adding the code above kills all my embeds and interactions on mobile for ? (testing on iPhone)

EDIT: Actually, now when I take a closer look it actually screws with all of the scroll interactions on desktop as well. Tested with Safari.

Much thanks to you such a great amount for examining this for me, Jörn. Anyway it didn’t take a shot at my site :befuddled:

I glued the code in the leader of my site, however for reasons unknown it executes all my install code and connections on versatile.


Glad I could help and its working for you :grinning:

That’s a Wordpress site you have there. FYI this is a forum for Webflow sites. It could be other plugins you have or custom code on your site that interfere with the code. Hard to help you with WP sites on this forum.

Great article dear. love your information.

How to download titanium tv Apk

Get titanium tv for Mobile


@vikaskundu Mate it’s not working for me. Followed what Jorn suggested but still not working. Can you help me out?

Regards, 9Apps
Cartoon HD Vidmate



It’s not working for me either.


Strange! As it works fine for me.

mx player apk