Form popup selector text cutoff on mobile iphone

looks fine on my mac. then, on iphone they’re cutoff inside the selectors. really odd. more interesting, the text was all the way to the left edge, and when i added 5px right padding for mobile, they moved. on the mac preview, nothing changed.

i’ve been trying all kinds of random values for the top and bottom padding, no dice. always cutoff. bug? how to fix?

Please provide your public share link. Thank you.

oops! no problem, it’s on the 2nd page in the site called “my page”:

EDIT: also, if it wasn’t clear, the only shows on the mobile browser, not in the preview in webflow. here’s a direct link to the published page: My Page

I see you have restricted the height of the dropdown fields. You can remove top and bottom paddings to allow more space for the inner text.

i tried that before, and it had no effect. i should have mentioned that. so… is this a bug?

EDIT: also, now that i’m looking at some other forms, i’m wondering why these selectors look so much different than the standard selectors?

below is the larger button test i re-did. but, i think the fact that jiggering with padding changes the position and “cropping” of the text, means something is happening somewhere. i’m afraid it’s with how webflow “constructs” the element, which we have no control over. next to that is the standard iOS safari selector, which is obviously vastly different, and quite small (vertically) with no problems. at the least, how do i get that selector?

EDIT 2 - reread your comment; there is no top and bottom padding, either. and, trust me, i’ve gone through 20-30 tests of all of them, padding and margin, nothing fixed it. some got better, then going farther made things worse. i even got it to show nothing inside! something is clearly very wrong.

It is a standard dropdown. There are paddings on it.

okay, i kind of see that. but, where is it coming from? this invisible mystery values are seriously infuriating. so, i’ve manually put in 0 values, even though i’m sure that’s what that class was already set to, before. that seems to have helped.

but, they’re still getting cut somewhat still. also, as mentioned previously, they’re missing their standard up down arrows like normal iOS selectors, which i think might be confusing for users. how do i get that to show?

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.