Domain possibly broken? Cannot connect to

Hello! I’ve almost finished a website on domain, problem is some people can’t easily open the website through this link, works and few other urls work too, but, does not, can anybody easily see the problem?

Thank you so much in advance for help! :slight_smile:

What is your default domain set to?

Accessing redirects to, which is usually the configuration you want. You likely had cached redirects.

@memetican - When I tested earlier I had SSL warnings.


I see those for an hour after the initial setup usually, it seems to take longer for the SSL certs to provision for Webflow over the past year.

1 Like

hello, do you still have those warnings? I think i solved it because i had one extra A dns record that shouldn’t have been there. Either way thank you for checking!

Is that just another problem with my domain? Cause i think i solved the problem i had (at least i think so, because i had one redundant A record in my domain settings - which i removed ofc), not sure if it directly affects my SSL certificate as well, but people that reported me they had the problem don’t have it anymore. Thanks for checking up!

Sounds like you’re all set them :slight_smile: nice work

1 Like