Streaming live at 10am (PST)

Disable horizontal scroll

I would like to disable horizontal scroll in my website for mobile view. I made “overflow” into “Hidden” for every elements in my website. But it doesn’t work.

I expect my audience to see like this: (without horizontal scroll)

But my website looks like this: (I don’t want to show this part)

Here is my site Read-Only:
(how to share your site Read-Only link)

@helen880201 m on my mobil now so I can look at the project but let me guess that you have a fixed with in one or more object in the mobil break ponint. Check IF you have fixed pixel size some where

I checked all the objects. NONE of them is fixed size…

@helen880201 Ok, will take a look at the project but can’t do that now. Will let you know When im at a computer. Ok?

@helen880201 i do have one more question before i can look in to it.
Do you have Any animation starting outside the view? Hidden objekts or similair?

@helen880201 i did take a qich look at yout project and yes you have a picture not fitting the mobile view. Its in the root of your body2, the class is called Top, there you have your problem.

You need to re think. im not sure what to suggest since you have your design. In all views except for computer you cover the whole page so my suggestion would be to use a section and use the picuter as background.

1 Like

Thank you for your advice! I am trying to use a section and use the picture as background.
But how can I adjust the height in order to show my complete picture? Now it only shows part of it.

@helen880201 When used as BG there are some options you can set depending of the size of the picture. BUT it will scale If it’s a BG. Try the image optios in the BG settings and se If you are happy or not.

If not put the image in a div and rezise the image for each device. It might work i have never tried

Normaly i use cover.

@helen880201 If its only the hight that is the problem you can Always set a min hight of the section.