Streaming live at 10am (PST)

CSS Grid is really Glitching Out

My bug seems similar to this one but I don’t believe it’s been solved by the webflow team quite yet. I will try the temp fixes but if anyone has more insight it’s appreciated. Basically, when hovering over my grid in mobile view (especially near the bottom) it starts to glitch. Other people have said this has something to do with hover states or nonexistent grid frames but I don’t see that in my case, this seems like a complex bug to me.

Here is a video, the glitch happens in the designer, as well as, in the preview and on the staging site:

UPDATE: I was able to find a workaround fix just by deleting the glitching grid element and then recreating it with the same classes I had created for it. I hope this helps others, thanks @davidvm for the tip.

Here is my site Read-Only:

Not to be snotty but you grid is saying there are elements placed in non existing grid tracks… See the message displayed in the top right corner with the yellow line next to it.
This is a known bug. It can take some time to find which item you didn’t place well.
I had this too, mine turned out a mobile menu button I forgot all about.

You’re not snotty at all Sarah, you’re awesome! I actually figured that it was likely non-existent grid tracks too… but I don’t exactly know what to do about it to avoid it as I am a newb to CSS grid. For some reason just deleting the glitching grid element and then recreating it fixed it. One thing that I do love about Webflow is that when you come across a bug there is usually a quick workaround fix until the team can get to a more permanent one, and the community is super supportive and cool, thanks for all your help!

There’s a technical explanation by the webflow team for this in other forum post about grid glitches. The way I’ve had it happen is when I had items and not enough rows to put them in so new rows got automatically added and messed with the positioning.
You’ll find it easiest to move grid items around if this comes up again using the rows/columns top right of the screen when editing grid :ok_hand:

Yeah I think it started happening when I started moving grid items around on mobile view, thanks for the tip!