CMS Links not working

Hi Webflow Community.

I’m having some issues with my CMS item links.

For some reason, webflow is adding “/en” to my links which is making them not work.

Example:

This is the link it’s producing: https://bloom-invest-v3.webflow.io**/en**/listings/mixed-use-conversion-opportunity

This is the link that works: Bloom Invest v3

So when I remove the /en manually the link works.

I just can’t work out why it is adding that in because I can’t see it in any settings.

For context, the item is wrapped in a link block, which is set to Current Listing for the link.

Any help is appreciated.

Thanks,
Miles

1 Like

Thanks Michael!

Incase it helps anyone else. This is the work around I’m using:

  • Create a new URL field in the CMS collection

  • Copy and paste the collection item url into this new URL box when creating the item

  • Link to this new url in the collection list