Streaming live at 10am (PST)

Brand link in navbar no longer work?

When I set: Navbar > Brand > Link setting to a URL or page and publish the site, the link does not work. When I hover over the brand link I see that the link address is always the current page where I’m at, followed by a #. All other nav links in the navbar works as normal.

Just me?

Here is a Read-Only link.

and link to the published site.

Hi @Christoffer

Our team is looking into this right now. For now the best workaround is to replace the brand with a regular link block.

We should have a fix out soon for this though — I’ll keep this thread updated. :bowing_man:

1 Like

Hello to all,

Hopefully someone can help my out with my brandlink in the navbar that I would like to link to the homepage. Although I’ve linked it to the homepage in the way Webflow’s tutorials showed me something must be blocking it. But after hours of trying I can’t figure out what the problem is here.
So, that’s why I’m now here, asking here if someone knows the solution. That would be super great!!

Here is my site Read-Only:

Best wishes,

Hi, it looks like a real bug actually, it would even happen on a brand new navbar element.

@brando I couldn’t find any solution for this, anytime a link is put on the Brand element, the link appears to be the one of the Designer, anyway, not any other link you’d affect to it. Thanks for looking at it, it looks like a bug.

same here :confused:

@lewis @Sonnebon @vincent

I went ahead and merged this thread with an existing one — this is definitely a bug.

The team is close to having a fix ready to go through QA. I’ll keep you all updated as we learn more.

For now the best workaround is to replace the brand with a regular link block.


Hey guys,
As in the title - the “Brand link” in navbar doesn’t work.
I already saw few questions about it. I tried to applied those advices but no results.


Any help appreciated as I am super new to webflow!

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey @paulina,

I tested out what you are saying and thats definitely is a bug. Not only link home isn’t working, but if you change it to another page it doesn’t as well. I even recreated a blank page just to test it out and it had the same error.

While the staff doesn’t fix that, here’s a workaround:

  • Insert a Link Block component in you Navbar
  • Give it the same class as you are using on you Navbar Brand
  • Point the link to the home page
    • Element Settings (D) > Link Settings
  • Drag you logo image inside the new Link Block you just created
  • Delete the original Navbar Brand Link Block

It should fix your problem.

I recommend you to create a Symbol of your navbar so you doesn’t need to recreate this processe on every page.

Here’s a recap video:

1 Like

Hey @PixelGeek, @Waldo, @Nita, @Brando or someone else from the Staff, check this bug out:

The Brand Link Block from the default navbar component is broken. It can’t be mapped to any link out of the box. After seeing this post from @paulina I tried several ways to make the link point to somewhere and it is just flat out not functioning. If you need some help I can show how to reproduce the error.

Thanks for the great job, guys

@gilson @paulina Yes you are definitely right — this is a bug for sure. Thanks for pinging us! :bowing_man:

I’ve gone ahead and merged your thread with this one which addresses the issue. The team is still working towards a fix, but as a workaround you can replace the brand with a standard link block.

1 Like

Thank you all for the responses!
The workaround is a perfect solution to fix the link.

All the best,

1 Like

Hi @Sonnebon @gilson @lewis @vincent @Christoffer

Thank you again for reaching out about this brand link issue.

​I wanted to let you know the team created a fix for the issue. We are deploying the fix soon, and the “brand” link should be working as expected in the next few hours.

Thanks again for your help and patience on this!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.