Streaming live at 10am (PST)

Bottom scroll activated when I dont want it there

On my website on the desktop view, I have a bottom scroll and my site slides from side to side but I don’t need it. everything on my site is centered. How do I disable it?

Site link here: Webflow - From Leads 2 Clients

I think the problem, is your Hero Tilt Block is 115% in width which will cause scrollbars vertically. Now to solve this, you can set the overflow to hidden on the body.