Streaming live at 10am (PST)

Youtube video not displaying well on mobile landscape view


  1. This is how the embedded youtube look on iPhone 6Plus landscape and iPad landscape views:

Does someone knows why is this happening? BTW in webflow designer all screen sizes look great.
this is the link to preview website:

  1. The second problem is that autoplay is not working neither on mobile nor tablet and after manually playing the video, when trying to close it, only the window is getting closed and the audio keeps playing.

Thank you,

Hey there Naama :slight_smile:

Maybe use the video component, not the embed widget ? And make it responsive as usual.

Concerning the video autoplay on tablet or mobile :

the different OS developers intentionally disabled autoplay on mobile devices in order to protect user’s bandwidth

Thank you for your answer @Blaise_Posmyouck.
Unfortunately the video component is not working properly.

Hello @Naama can you please provide a little more information regarding the video component “not working properly”?

Screen shots, videos and your Read-Only link are extremely helpful (looks like your current read-only link has expired, can you please post a new one?)

Hi @Waldo.
The video is not displayed on wide screen, the autoplay is not working and the close button is not really closing the video, only hiding it.
This is read-only link:
The video is in the page called “Xirrus case study” -> section “Xirrus video”

Thank you very much,

Hi @Naama, could you tell what is not working properly for you using the built in video component? To style embedded video as responsive, check this article: [Tutorial] Responsive Video using HTML Embed

Regarding the autoplay on mobile, that is disabled in iOS by default, and normally shows the play button (assuming the embed code options are correct).

My advice would be to use the built in lightbox for your youtube videos, or create a custom modal and then control the video playback/controls using javascript instead of an using an iframe.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.