Streaming live at 10am (PST)

Wordpress Webflow Pages API Key Failing - Was working, now failing?

Hi Everyone,

My first time posting, so hopefully my question hasn’t been answered 100 times before…

I’m currently using the Wordpress Webflow Pages app to pull in pages to a large Wordpress site.

Yesterday I was able to successfully connect using the API, but it unexpectedly disconnected and I’ve not been able to reconnect the site.

I’ve tried repeat times to create a new API key, and update it in Wordpress, but I’m always presnted with “The API key failed. Try publishing your Webflow site first”

The site is published, and I can’t see any obvious issues.

For reference, this is the first page I’ve finished and plan to add to show it’s live: https://logogeek.webflow.io/logo-design-process

I then plan to add this to replace this page here: https://logogeek.uk/logo-design/process/

If anyone has any ideas what might have caused it to suddenly disconnect I’d greatly appreciate the help. I’m relying on this to update my site, so I hope it’s not a common issue.

Many thanks,

Ian

Hi,

I’m having a similar problem.

Did you find out how to fix this?

Thanks,
C

Hello,

I too got the same issue when I added a siteplan in order to remove the webflow badge. I tried deactivating the webflow wordpress plugin and reactivated it. It automatically connected to the API I was trying to add.

Thank you
Sai

Hi all! I have similar problem,
when I add API key everything looks good in Wordpress Webflow page plugin, it even saay that everything is sucessfull, but when I go to check on publishing site (to WP adress) there is nothing, only parts of WP Theme page and BLog text that I try to erase all in setings but they there are…
Can anyone help me with these?
Cheers

Hello!
I’m having the exact same issue! I built my website in AWS, and installed everything fine. When I uploaded the Webflow plugin, however, I get this message: “The API key failed. Try publishing your Webflow site first”
I’m bumping this thread, because i seems to be a growing issue.

Thanks