Wistia videos not working in Rich Text CMS


I am trying to add a wistia video to rich text in a CMS post.

Webflow supports wistia (according to their university), but it is not playing. it just loads in a very blurred thumbnail on publish.

It accepts the url, so it should be working, but isn’t.

Any help would be greatly appreciated.


Can you link the video you’re trying to embed? This might be a temporary issue on Wistia’s side… when looking for a video to test I found this link, which doesn’t seems to load a video, just a blurry thumbnail:



I can’t link it sadly as the video and site contain sensitive information for the client.

Any youtube link i try in the rich text video url bit works fine.

Maybe it is wistia, but their videos work fine if embedded into the site normally. its just in the rich text editor they are breaking.


How is that? I found some other links that have the same issue. There is an error in their iframe… I imagine they’ll fix it soon.

using the embed widget on a normal page i can get a video to work. its just the rich text url version for wistia thats busted. at least for me.


Try again? I think they might have just fixed it.

Edit: yep:

The rich text and video element versions use Wistia’s iframe player, which loads an iframe like (https://fast.wistia.net/embed/iframe/avk9twrrbn) … their HTML embed codes load some javascript to load the video element into the page. I think it was their bug, but only in the iframe version.


ah yeah, works now!! thanks for the help! glad it was just a temp bug. much appreciated! :slight_smile: