Why won't Webflow respond?

I have a bug with Webflow regarding to change an e-mail address in the CMS! And I have written to them no less than 3 emails about this. But they don’t answer this problem? They just send the usual email that they are busy…etc.
But there is an ad currently running on the website, - and the correct e-mail address must be listed, - but the people only see the old e-mail address, - which has been there for the last 8 years and doesn’t work anymore! - So it is important for our members that the new e-mail is visible on the website, - but I have published and published this new e-mail on the CMS, - but it does not change when the website is public, - it is written correctly on the CMS program , - but Webflow take the old e-mail publich when published the website. So why does the old incorrect e-mail address appears all the time. And why won’t Webflow respond me?

Then I had a new problem again today.
I deleted 2 lines on a CMS and published.
But this deleted 2 lines didn’t appear on the website??
I have now tried to publish several times, and still this change does not appear on the website.
I’ve tried several browsers, and also on the iPhone, and it says the same thing: No changes?
But changes have been made to the CMS.
What is wrong with Webflow at the moment??