Why some typo style (like light) are not available?

Why some typo style (like light) are not available ? Google font offer them all. Is there any kind of restriction ?

Different fonts come with their own font weights. Which Google font are you looking at specifically?

OK there is two main issues.

First point, here is a screen shot from my Mac Keynote App. I import Open Sans from Google Fonts. I can count 10 styles. In webflow the is many not available.

Second, even within the same project, sometime the style is randomy appearing or not. See it on my videocast - http://cl.ly/193d1k053D0u

Thank you

Thanks for letting us know @devmtl. We removed some of the weights so that there are less fonts to load for our users. But we just added all of the missing ones for Lato, Open sans and others.

In Webflow there are actually 10 styles available, but they are broken down into Weights (font-weight property in css) and Italic (font-style property in css). There are 5 normal weights and there are 5 italic variants for those font weights. So when you select Bold, for example, you can also select Italic property on the right of the weights to get to the other 5 fonts.


Does that help answer your question?

As for the weird behavior you’re running into with not being able to choose the font weights that’s super weird. It looks like the font on the right of your video is Arial, not actually Lato. What’s your subdomain? I can look to see what’s going on in more depth.

@thesergie I can see that you added fonts for lato, great !
But for Open sans … light & ultra light are missing and I really need them.

Can you add those too ? Thank you very much :smiley:

@devmtl, Open Sans only has 400 and 300 weights. (Btw we call 300 “Book”, but we are changing that to “Light” so it’s consistent with Google and Typekit).

From Google Fonts:

They don’t have an ultra light. Where did you find an ultra-light? (In general I wouldn’t go below 300 because a lot of computers out there do not render very thin fonts well so it would be hard to read! So just test it!)


I imported this typo in Keynote and they are all there. See the screens shot I send 5 days ago.

Thank you !

I’m looking at your screenshot for open sans too and I don’t see an ultra-light either. Additionally, there is no ultra-light here: Google Fonts: Open Sans …but you have actually found a bug, I’ll explain.

I watched the video you provided where lato shows ultra-lite as an option for the first font but not for the second element you selected. If you look at the actual font you selected the second time, it isn’t actually lato (even though that’s what it shows), its some other font. I think you see lato because that is the last font you worked with. This is the bug I think. I have experienced this too. If you had clicked on the font type drop down vs the font weight, you would have seen that the “real” font would have been highlighted in the drop down list and if you then selected lato, the font weight would have given you the ultra-light option.

1 Like

Yeah I don’t see an Ultra-light in your screenshot or in Google fonts. Open sans doesn’t come with an ultra-light.

@pingram3541 you’re right there’s a bug that doesn’t show the correct font. We’re working on fixing this.

you are right ! _________

It seems like there is a extra light version available now could you add this to webflow?

1 Like