Streaming live at 10am (PST)

Weglot not translating

Title pretty much says it all. I have weglot integrated on my website and it doesn’t translate items present in the cart.
It also does not translate the “wait” button that shows up while the item is being added in the cart.

Ive tried adding the following lines in the weglot dynamic settings (class and ID):

.w-commerce-commercecartitem cart-item
#w-commerce-commercecartitem cart-item

These don’t do anything, or maybe i’m doing it wrong?

I understand this might be an issue that should be asked to the weglot devs, but i thought maybe someone had some sort of insight here.


Hey @Kimmy, can you contact our support team at We might have a solution for this.

Thanks, just sent an email.

Quick update: If anyone ever has an issue with weglot not translating items in your cart, you can email them at and they will help you, it basically just requires you to find out the correct classes and inserting them in the weglot’s “webflow” settings.

Also, classes can’t have spaces between the names, you’ll have to inspect your page and find out the right class names so that you can copy and paste them in weglot’s settings.