Weglot Custom Language Switcher Not Working

Hi, I’m trying to add a language switch to my site and I’m struggling with the custom code. The standard language switch button works but none of the custom code ones work.

I followed all the steps of this tutorial from the custom UI kit: Custom UI Kit | Weglot for Webflow - YouTube

I just signed up for a free trial so I’m trying to figure out if it’s not working because of the free trial or something else.

Here is my site:


Hi @Natalie_Gendron,

It looks like you’re missing a closing </script> tag in Page Settings > Custom Code > Before </body> tag.

It might be worth double checking you pasted all the code from Weglot over!


Thanks for the help, I went back and added the closing and double checked the coding but no luck :frowning:

Hi @Natalie_Gendron,

Looking at this tutorial video it looks like you’ll need to add the links and some code to Project Settings > Custom Code > Head Code:

Could you make sure this is correct?