Website showing desktop version on all devices


I’m having issues with a site I’m making. I’ve tried to make it really simple but it just won’t work as I thought. Everything looks great in Webflow but when the site is live it just doesn’t go into tablet or mobile view on those devices, it keeps showing the desktop version (which doesn’t look bad, just not the way I want). I’m thinking it’s something simple that I just don’t get! I’ve looked through the forum and have tried different things but nothing seems to work.

I’m hosting the site through ftp upload, so I’ve exported the code from Webflow.


Live Site

All help is appreciated!

@Annika_Marmen try use grid

Thank you! I am however having the same issue with other pages on the site, for example where I’ve used grid.

And it’s all working in Webflow, different breakpoints looks great. It’s also doing what it should in browsers, when I minimise the window. It’s just that the phone and tablet won’t show anything but the desktop version. Driving me insane! :slight_smile:


Strange. I’ve tested the published site on Safari (developer mode) and the breakpoints worked just fine) - My handset (iPhone 5s) shows the desktop version.

The same for me!

  • I’ve checked the css, nothing broken or weird
  • I don’t see how it could be an upload issue since the site works on desktop browsers
  • I have all elements on auto height and width, works seamlessly in webflow, I’ve only adjusted some margins and font sizes slightly

It sounds like you may have already covered this, but just in case…

I have found that when trying to eliminate unused CSS with an export it doesn’t work very well (some times at all) with breakpoints.

Are you taking the files exactly as is and hosting? Anything your host may be doing to the files?

Thank you! I haven’t touched the css or any of the files at all, I just import them into the public_html folder.

I might call the hosting company tomorrow though and see if they can figure it out :slight_smile:

Actually, I just checked out the HTML and it doesn’t look right…

The Webflow content has been set inside a frame - this is almost definitely the issue.

Is this a ‘standard’ host, or is there something special about it? Would you expect the HTML to be manipulated slightly?

THANK YOU! I researched a bit into this and found that the issue was that I had masked redirecting going on, pointing the domain name from one host to the other. Removing the masking did the trick.

I feel so stupid now :slight_smile: Thank you so much everyone for advice!

1 Like