Website domain not working after publishing edits


My website domain doesn’t work when I publish my website edits. I have contacted Google Domains already and they confirmed that all the records are properly added, the website is already connected to my domain and it’s not under propagation delay. They also advised me to reach out to Webflow since Webflow manages my hosting services and I want to make my website work.

This is what the website link currently shows:

Can you please assist me with this?

Hi Jessie, I don’t see your www CNAME record, you should double-check that in your DNS.
What does your site’s hosting settings page report as errors?

How do I double check in my DNS?

Log in to Google Domains and check.
You need to have a www CNAME record- Webflow has instructions on the site settings page.

I’m currently watching the “connecting a custom domain with google domains” tutorial video. is the CNAME value always “”?

I just added extra records on Google Domains (view photo below):

but I’m still seeing this issue on Webflow:

Looks 90% right- I’m not familiar with Google Domain’s DNS interface, but it looks like there are double-quotes in your TXT record. If it’s just Google’s way of displaying that value you’re ok, but if it’s actually in the value, it won’t work.

I’d edit that TXT value and make certain it is not;


But instead just;

Actually I think you’re probably ok, I’m seeing this on a DNS query-


Still I’d double-check.
Other than that, it sometimes just takes a bit for DNS propagation to happen, and for Webflow to pick up every record.

Try publishing your site and see what happens.

Looks like it’s just the syntax – even after deleting the quotation marks and saving changes, Google Domains re-populates the quotes and period at the of for CNAME as well. at least the error on now looks different:

yeah, it could take a while to load. are you also seeing this error when on

Almost there. Set the www version of your name as the Default domain in your site settings and republish.

it worked!!! thank you so much :slight_smile:

1 Like