Website appearing as blank due to incorrect DNS records

Hi there,

A website I created over a year ago on webflow has all of a sudden started appearing as blank when viewed in Chrome. It was working fine up until recently and I can’t figure out what I’ve done wrong. The read only link is

and the website address is


website loads for me… try restarting the computer.

Sorry I should have been more clear. The actual website loads as just a blank screen not the webflow designer.


Still working for me.

Try clearing out the cache / restarting browser.

I have done all of that and it still doesn’t work for myself or my client. I’ll take a look at the dns.


You can also try checking out the site in incognito mode with all browser extensions disabled. Extensions can sometimes interfere

Hi @PhilipM I took at look at your DNS settings and I’m seeing an extra A Record that is non-Webflow which would result in your site coming up blank:

You will need to delete the A Record pointing to:

Thereafter, be sure to go into your site settings, set a default domain and publish your site to your custom domain.

​Please let me know if this solves the problem, if not, I’m happy to help further.

1 Like

I can’t seem to see that A record in my dns zone editor. However I actually leave that extra A record in there for all of my webflow hosted websites otherwise the emails stop working for said domains. None of my other websites on webflow are having this problem.

The website seems to be working on the desktop version of chrome but it still doesn’t work on mobile.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.