Webflow's automatic sitemap doesn't include www

Hi there, how do you make sure Webflow’s automatic sitemap includes the www protocol? Is there a setting?

For some reason, our sitemap doesn’t include www in the URL, which means the sitemap is wrong since it has to keep redirecting to www, and our pages are taking longer to be indexed.

For reference, our website is www.parpera.com, but the sitemap is registering https://parpera.com and not https://www.parpera.com


Here is my site Read-Only: [https://preview.webflow.com/preview/parpera?utm_medium=preview_link&utm_source=dashboard&utm_content=parpera&preview=3b281e0c16a20f138571eb460ad0f0a3&workflow=preview]
(how to share your site Read-Only link)

Hi Araminta,

Did you ever find a solution for this?

BR

I’m having the same problem. @araminta @105bpm have you found the solution for this issue?

Hi @Rashmi_Maharjan,

To fix this issue, you need to set the full domain (www.domain.com) as the default domain.

  • Go to Project Settings > Hosting/Publishing > Custom Domain
  • Set the www version of your domain as the default domain.
  • Publish your site

You can then check your sitemap to see if this has been updated!

Let me know how you go. :grinning:

A client of mine is experiencing this issue, but the www domain is already set as the default domain in webflow.

Is there another issue that may cause this?

Hey Scarlett,

As long as you’re certain that the WWW version of the name is set as default, and you’ve republished the site, your sitemap.xml should be generated with the default domain name including that www.

I’d probably-

  • Set a different domain as default
  • Republish
  • Set my www domain again default
  • Republish
  • Check sitemap.xml

If that doesn’t work, you’ll want to contact Webflow Support.

1 Like