Webflow site works extremely sluggish and slow on Chrome


I’m building portfolio site in Webflow and it runs extremely sluggish and slow on Google Chrome
while when I test in Safari it runs smoothly and without any issues.

This is screen capture from Chrome

This is screen capture from Safari

I also tested website on numerous other Mac computers and it’s the same thing.
I tested numerous other portfolio websites built on Webflow and most of them have the same issue.
I didn’t tested site on Windows machine because I don’t have access to one at the moment.

I used fnsweet attributes and some other code on website, but I even duplicated website deleted all
third part code and deleted all interaction from website and performance was still bad.

The only logical answer I have is that Chrome is struggling to render JPEG images, and Webflow does not support AVIF or WebP formats so thats the reason for poor performance.

This is link for my website

To note that I done every possible thing to up the performance of Chrome, deleted cookie’s, cleared browsing history, updated everything, turned off all Chrome extensions and the performance was still the same.

So my question is, do you have similar issues with your Webflow websites in Chrome and is there a way to fix this somehow

Thanks in advance

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

1 Like

Anyone have same issues with Chrome, any help with this?

1 Like

Hey @Marko_Gole, I have the same issue with Chrome. It’s very sluggish and laggy. When I look at your site, it seems to work very smoothly. Did you find a solution?


Hey Mark,

I’m experiencing the same issue with Sluggish Chrome. It started occurring about a month ago and I haven’t done anything to the site design that would encourage the slow down. The site loads well using Edge and Firefox on the same machines, so it seems to be an issue with Chrome. Especially when it comes to loading json files.

Did you find a solution?

No, I tried many things, contacted support and what not.
My guess is after testing on different machines Mac and PC’s that the issue is Mac’s with Intel chips on Chrome… Maybe my assumption is wrong but it’s the best I have…

I’m having the same issue and it’s only recently started with Chrome. Runs fine on Safari, hoping for some good news soon!