Webflow Pages Wordpress Plugin - 404 error for CMS and sub-pages

Hello, I’ve got issue with Webflow Pages Wordpress Plugin. I correctly installed and activated plugin and connect it with generated Webflow API code.

I’ve added correctly page and CMS rules and published my Webflow Website and home page works perfectly fine, but the sub-pages and CMS pages are displaying 404 error…

Could you please help me resolving this problem?

The wordpress site: http://193.192.178.201/
Webflow site: https://stimo.webflow.io/
Read-Only Webflow: Webflow - Stimo.pl

I’m still stuck with this problem. I’ve also noticed that wordpress creates automatically untitled pages with no content called “Untitled” (bez tytułu).

Could anyone help me please?

Could you post your Webflow Pages plugin page too? The one where you put in the homepage, cms stuff etc.

Now it’s: http://stimo.pl/

No, an image showing the wordpress webflow plugin page settings with the list of pages. I can’t see what’s wrong from the published page or webflow page…

Of course, sorry for misunderstanding :slight_smile:



Everything looks fine as far as I can see. Maybe try removing the settings and set it up again? Remember to publish the page in Webflow too.

Don’t remove the blank pages btw. Not sure what they do, but I think those are there for a reason.

Thank you for your reply.

I’ve multiply tried to remove setting. I’ve even tried to delete whole databese and created a new Wordpress installation and it make any change…

Sounds like a bug then :frowning: You should contact support.

That’s what I did.

Thanks for your cocnern :slight_smile:

Do you resolve this issue? I’m having the same problem.

Yes.

The problem was on client’s hosting which did not allow WordPress’ .htaccess to overwrite the default settings and was putting /index.php/ prefix between site url and permalink.

I had to change the configuration on hosting described in this link, so it solved my problem:

Hope it will help you.