Streaming live at 10am (PST)

Webflow nav menu only opening on some pages (SOLVED)

Any clue why my stock Webflow nav menu will open on some pages, but not others?

For example, if you go to:

Home page: (it doesn’t work)

If you go to: (it does)

This should be the exact same “Symbol”.

Any thoughts or fixes?

Here is my site Read-Only:
(how to share your site Read-Only link)

1 Like

Works fine on both pages for me. Try deleting the cache :webflow_heart:

Thanks for checking Piter. I did delete cache and still get the problem on my iPhone XS and on my iMac using safari. Oddly enough it works fine in Firefox on mac, but not on iPhone

If it’s any indication, if I click on the menu nav-burger item before the page is finished loading. it will work…the page appears to quickly load on top of the menu and then it disappears.

Turns out the nav WAS opening, but the Z-index on the div-blocks directly below were covering the nav to appear as if they weren’t opening.

I did further research on the forum and it seemed like that was a logical explanation. Turns out… it was.

The new question is…why would some browsers show it fine, and others not? There appears to be some inconsistencies here.