Video not autoplaying on remote desktop

I am developing a website for customer in Webflow with a fullscreen video on the frontpage autoplaying - working great. However the customer is using remote desktop and here the video is not autoplaying… can anyone tell me why and what could be done? I am using the video component within Webflow.

Also I have seen other websites developed in Webflow with autoplaying videos… and that is the same, they dont autoplay on remote desktops.


Here is my site Read-Only:

What do you mean “remote desktop”? (What browser?). In general you should mute autoplay videos.

  1. What kind of video (Webflow video widget? Background video widget? Embed Html Video?)

The video is muted (no sound) and it doesnt matter which browser he use its not autoplaying.
Its a background video.

background video webflow widget

Add live URL.

Hi Ezra

Thanks but I am not sure why you send me this… I know how to implement the video and also know about the different settings… I just dont know why autoplaying is not working when users are using/working on Remote Desktops.

@KimHougaard - Sharing a URL that can be debugged in a browser is essential to figuring out what is wrong. Also you really need to share the client’s build (what OS, OS version, browser, and browser version. I won’t test without it.

Hi Webdev

Thank you for your reply and sorry about the URL i thought sharing my webflow link was enough. But the site is here right now. and its the video on the front.
The customer has ben testing in both Explore and Chrome (not sure what versions, but i am pretty sure its not old)


Consider using to gather the info.

Also remember that modern devices support user preferences when it comes to motion. See Designing With Reduced Motion For Motion Sensitivities — Smashing Magazine

Thanks. I will have to get back to you on this one. I need this informations from the customer.