Urgent - place order cta not working - checkout page


Hope my message finds you well.

I am reaching out as I am facing a serious problem with my Webflow site. One of my customers can’t purchase an item and after checking where the issue comes from I believe it can affect all users trying to purchase any items.

I have been checking on Hotjar to see what’s happening. I can see users have been through every step properly including product page → add to cart → checkout. Nevertheless, on the checkout page, I can see that the CTA to place an order is not working.

The customers have been trying several times including on Mobile and Desktop but the CTA is still not working. I have also republished the website but nothing has changed. Perhaps the discount code he is using at checkout can affect the CTA?

Is someone can help me out, please?

Many thanks for your time given,
Aurélien from Drover Club


Can someone have a look, please? My CTA is still not working and users can’t purchase on my webflow site!