Streaming live at 10am (PST)

URGENT - JS not working for no reason. Native anchor links are not working

Here is the live site - “Tell me more” button is an anchor link to a section, not working properly.

Page scroll animations have stopped working.

What is going on?? Everything was working an hour ago.

Share link

Everything is working on my end. Are you still experiencing issues? If so, can you try opening up the website in incognito mode with all extensions turned off?

Yes still having the issues. But yes it does work when I open on incognito in Chrome.

Any idea how to make it work again when not on incognito?

Open up the website normally and then check the DevTools console for any errors. This will point you in the direction for the extension that may be causing issues.

It also works fine on my end:

Thanks for your feedback guys, much appreciated.

Have switched off all extensions also and the issue is still there.

Are the scroll interactions with background colour changes further down the page working for you?

So when you disable all the extensions the problem persists, but not when you visit in incognito?

Once you load up the page, right-click and choose “Inspect” and then choose the Console tab on the window that opens up.


Do you see anything in red shown here? If so, can you take a quick screenshot of what’s displayed? This will help narrow down the issue.

Yes that’s correct, thank you, here is the screenshot

So it looks like an issue with your browser blocking the JQuery code due to it not being on the same domain, and while I see a couple threads about this issue on the forum I can’t find a solution. It’s strange that you would be experiencing the problem and not others, and it doesn’t appear to be a problem you created as this code is injected by Webflow.

I’d recommend reaching out to Webflow Support to see if they can give you some insight. You can do this in your project by selecting the Help & Feedback link within the question mark menu in the bottom left of the designer and then clicking on the “Send us feedback or a help request” link on the following window.

Right yea that seemed to me what the errors were saying too that the JQuery code was being blocked. I have reached out to WF Support already about it but will do again with the details you’ve given. This is really not great timing unfortunately. Hopefully they’ll respond soon.

Thank you so much for your help, much appreciated.

Problems never happen at opportune times, or else they wouldn’t be “problems”—but the fact that some folks aren’t experiencing the same issue means that it may be localized to only a small amount of users.

In the meantime, can you try republishing the site? I know there are some publish options that you may want to try enabling/disabling to see if it fixes the issue.

Very true! Almost strange timing with this one though, wondering if someone has hacked me or something!

Have tried republishing to both the .com and domains, and same situation.

Previously tried changing the page to not be the homepage but that did nothing

So not sure why or how but the issue stopped happening :raised_hands: Thanks @mikeyevin for your help on this, truly appreciated.

1 Like

Glad to hear the issue resolved itself!