! URGENT Help Needed: Back up version feature no longer working

I have been using the ‘backup versions’ feature on Webflow for years and it always worked seemlessly before. I even name some of my backups.

Today, after hours of work, I tried to do revert to a previous backup and it does not work. It doesn’t matter what backup version I try to restore, none of them work. It just keeps showing the current build I last published. I tried other browsers/computers so it’s not the cache.

This is a huge emegency as we provide services for thousands of customers who are hospital patients and the part of the page I need to restore is the navigation bar - so critical & entire site won’t work without the nav working.

I sent a support ticket/email, and the ‘response’ email I received said they are busy and it will take time for them to respond. I hope someone here can give me some options or any advice/recommendations.

Huge thanks for your time and assistance.


Here is my public share link: LINK
(how to access public share link)

I ended up staying up all night and recreating my navigation - so this is now resolved - but not resolved as well because the backup failure did happen & now I will never trust it again in the future - neither should any of you.